June 26

Install TOR di OpenWrt Router Huawei HG553

untuk detail mengenai TOR silahkan googling sendiri ya….

konfigurasi yang saya pakai

  • koneksi internet menggunakan modem
  • jaringan yang menggunakan TOR hanya via wifi, tidak bisa digunakan untuk mengakses router. koneksi internet melalui wifi akan menggunakan TOR. IP 192.168.2.1
  • untuk mengakses router harus menggunakan LAN. koneksi internet via LAN tidak akan melalui TOR. IP 192.168.1.1

Install TOR

opkg install tor iptables-mod-nat-extra

tambahkan setting berikut sesuai dengan file yang  dimaksud

/etc/config/network

config interface ‘tor’
option proto ‘wlan0’
option proto static
option ipaddr 192.168.2.1
option netmask 255.255.255.0

/etc/config/dhcp

config dhcp ‘tor’
option interface ‘tor’
option start ‘100’
option stop ‘150’
option leasetime ’12h’

/etc/config/firewall

config zone
option name tor
option input REJECT
option output ACCEPT
option forward REJECT
option syn_flood 1
option conntrack 1 #this setting is mandatory

#open the port of the DHCP-Server, so that the clients get an ip
config rule
option src tor
option proto udp
option dest_port 67
option target ACCEPT

#TOR transparent-proxy-port (set in /etc/tor/torrc)
config rule
option src tor
option proto tcp
option dest_port 9040
option target ACCEPT

#TOR DNS-proxy-port (set in /etc/tor/torrc)
config rule
option src tor
option proto udp
option dest_port 9053
option target ACCEPT

/etc/firewall.user

iptables -t nat -A PREROUTING -i wlan0 -p udp –dport 53 -j REDIRECT –to-ports 9053
iptables -t nat -A PREROUTING -i wlan0 -p tcp –syn -j REDIRECT –to-ports 9040

/etc/tor/torrc

VirtualAddrNetwork 10.192.0.0/10
AutomapHostsOnResolve 1
TransPort 9040
TransListenAddress 192.168.2.1
DNSPort 9053
DNSListenAddress 192.168.2.1

lakukan koneksi via wifi, buka browser ke check.torproject.org lihat apakah TOR sudah berjalan atau belum

 


Tags: , ,
Copyright 2017. All rights reserved.

Posted 26 June 2015 by mahendra in category "Tutorial

2 COMMENTS :

  1. By San on

    fungsinya install TOR di router apa ya ? apakah kita jadi tidak usah install TOR di laptop, otomatis menggunakan TOR saat surfing internet dengan router tsb ?

    Reply
    1. By mahendra (Post author) on

      betul, supaya otomatis menggunakan TOR saat surfing menggunakan router tersebut, laptop, hp, tablet

      Reply

Leave a Reply

Your email address will not be published. Required fields are marked *