June 26

Install TOR di OpenWrt Router Huawei HG553

untuk detail mengenai TOR silahkan googling sendiri ya….

konfigurasi yang saya pakai

  • koneksi internet menggunakan modem
  • jaringan yang menggunakan TOR hanya via wifi, tidak bisa digunakan untuk mengakses router. koneksi internet melalui wifi akan menggunakan TOR. IP 192.168.2.1
  • untuk mengakses router harus menggunakan LAN. koneksi internet via LAN tidak akan melalui TOR. IP 192.168.1.1

Install TOR

opkg install tor iptables-mod-nat-extra

tambahkan setting berikut sesuai dengan file yang  dimaksud

/etc/config/network

config interface ‘tor’
option proto ‘wlan0’
option proto static
option ipaddr 192.168.2.1
option netmask 255.255.255.0

/etc/config/dhcp

config dhcp ‘tor’
option interface ‘tor’
option start ‘100’
option stop ‘150’
option leasetime ’12h’

/etc/config/firewall

config zone
option name tor
option input REJECT
option output ACCEPT
option forward REJECT
option syn_flood 1
option conntrack 1 #this setting is mandatory

#open the port of the DHCP-Server, so that the clients get an ip
config rule
option src tor
option proto udp
option dest_port 67
option target ACCEPT

#TOR transparent-proxy-port (set in /etc/tor/torrc)
config rule
option src tor
option proto tcp
option dest_port 9040
option target ACCEPT

#TOR DNS-proxy-port (set in /etc/tor/torrc)
config rule
option src tor
option proto udp
option dest_port 9053
option target ACCEPT

/etc/firewall.user

iptables -t nat -A PREROUTING -i wlan0 -p udp –dport 53 -j REDIRECT –to-ports 9053
iptables -t nat -A PREROUTING -i wlan0 -p tcp –syn -j REDIRECT –to-ports 9040

/etc/tor/torrc

VirtualAddrNetwork 10.192.0.0/10
AutomapHostsOnResolve 1
TransPort 9040
TransListenAddress 192.168.2.1
DNSPort 9053
DNSListenAddress 192.168.2.1

lakukan koneksi via wifi, buka browser ke check.torproject.org lihat apakah TOR sudah berjalan atau belum

 

June 26

Install driver modem offline OpenWrt Huawei HG553

Setelah install fresh openwrt di HG553 mungkin modem yang kita pakai tidak akan dikenali oleh router. untuk install driver(modul) langsung dari router tentu memerlukan koneksi internet via lan serta merubah konfigurasi salah satu lan menjadi wan seperti disini  . bagi yang tidak punya koneksi internet via lan, lakukan saja installasi modem secara offline

karena saya menggunakan versi barrier breaker, maka file modul bisa di download di disini

berikut daftar file yang perlu di download

  • chat_2.4.7-2_brcm63xx.ipk
  • comgt_0.32-23_brcm63xx.ipk
  • kmod-nls-base_3.10.49-1_brcm63xx.ipk
  • kmod-usb-core_3.10.49-1_brcm63xx.ipk
  • kmod-usb-ohci_3.10.49-1_brcm63xx.ipk
  • kmod-usb-serial-option_3.10.49-1_brcm63xx.ipk
  • kmod-usb-serial-wwan_3.10.49-1_brcm63xx.ipk
  • kmod-usb-serial_3.10.49-1_brcm63xx.ipk
  • kmod-usb-uhci_3.10.49-1_brcm63xx.ipk
  • kmod-usb2_3.10.49-1_brcm63xx.ipk
  • libpthread_0.9.33.2-1_brcm63xx.ipk
  • librt_0.9.33.2-1_brcm63xx.ipk
  • libusb-1.0_1.0.9-1_brcm63xx.ipk
  • luci-proto-3g_0.12+svn-r10530-1_brcm63xx.ipk
  • usb-modeswitch_2014-07-18-01ecc3b9764d1dd89cf36ede0a2d98f9adb0cd33_brcm63xx.ipk

perhatikan nama modul saja, versi mungkin berbeda

copykan semua file diatas ke folder /tmp untuk lebih mudahnya bisa menggunakan WinSCP

selanjutnya buka putty, jalankan perintah berikut

opkg install /tmp/*.ipk

setelah semua modul terinstall, pasang modem kemudian restart router. seharusnya sekarang modem sudah dikenali oleh router

January 27

Menjadikan Huawei HG553 sebagai print server

Fungsi asli Huawei HG553 ini salah satunya sebagai print server, oleh karena itu di OpenWrt ini fungsi tersebut akan kita aktifkan kembali

Karena tidak terbiasa dengan vi, maka kali ini kita install nano, text editor yang lebih familier bagi saya, sekaligus kita install USB Basic support

  1. Buka putty, kalau belum tahu silahkan lihat artikel sebelumnya
  2. Hubungkan ke router Huawei HG553. pastikan router terkoneksi internet
  3. Jalankan perintah berikut

    opkg update

    opkg install nano usbutils kmod-usb-ohci kmod-usb2

    opkg install luci-app-p910nd p910nd kmod-usb-printer

  4. Tancapkan Printer (saya pakai HP Deskjet 2520 Series)
  5. Ketik perintah berikut

    find /dev | grep lp0

    lp0

  6. mungkin hasil yang muncul adalah /dev/usb/lp0  , ini adalah lokasi printer yang akan kita pakai
  7. Selanjutnya kita edit konfigurasi firewall

    cp /etc/config/firewall /etc/config/firewall.bak

    nano /etc/config/firewall

  8. Tambahkan Rule berikut. tekan Ctrl + O kemudian Ctrl + X untuk menyimpan file

    config rule
    option src ‘br-lan’
    option proto ‘tcp’
    option dest_port ‘9100’
    option target ‘ACCEPT’

    firewall-printer

  9. Ubah juga file P910nd

    nano /etc/config/p910nd

  10. Replace isinya dengan konfigurasi berikut, sesuaikan lokasi printer dan IP dengan konfigurasi anda

    config p910nd
    option device ‘/dev/usb/lp0’ #lokasi printer
    option port ‘0’
    option bidirectional ‘1’
    option enabled ‘1’
    option bind ‘192.168.2.1’ #alamat lan

    p910nd

  11. Selanjutnya di Win7, pilih add printer. konfigurasinya disaya seperti berikut

    IP    : 192.168.2.1

    Port : 9100

    Protocol : RAW

    printer

Silahkan dicoba untuk print test page

 

January 27

Merubah Port Lan menjadi WAN di Huawei HG553

Installasi OpenWrt di huawei HG553 sudah selsai, selanjutnya yang ingin dilakukan adalah menginstall modul modul tambahan supaya bisa mengenali modem, print server dan sebagainya.

karena koneksi internet yang tersedia berupa kabel LAN, maka salah satu port LAN yang ada di Huawei HG553 harus diubah menjadi WAN.

untuk melakukan hal ini, mungkin anda akan memerlukan

  1. PUTTY
  2. WINSCP.

silahkan download pada link yang saya berikan diatas

  • Menggunakan PUTTY

putty

 

– login as : root

– password silahkan diisi sesuai password router anda

– ketik “vi //etc/network/config” tanpa tanda petik

– replace dengan konfigurasi berikut

config switch ‘eth0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘eth0’
option vlan ‘1’
option ports ‘0 1 2 5t’

config switch_vlan
option device ‘eth0’
option vlan ‘2’
option ports ‘3 5t’

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth0.1’
option proto ‘static’
option ipaddr ‘192.168.2.1’
option netmask ‘255.255.255.0’
option nat ‘1’

config interface ‘wan’
option ifname ‘eth0.2’
option _orig_ifname ‘eth0.2’
option _orig_bridge ‘false’
option proto ‘dhcp’

– Simpan kemudian restart

  • Menggunakan WinSCP

 

winscp

– masukkan IP router, username dan password

– arahkan ke folder /etc/config

etc-config-network

– klik 2x pada file network

– replace dengan konfigurasi berikut

config switch ‘eth0’
option reset ‘1’
option enable_vlan ‘1’

config switch_vlan
option device ‘eth0’
option vlan ‘1’
option ports ‘0 1 2 5t’

config switch_vlan
option device ‘eth0’
option vlan ‘2’
option ports ‘3 5t’

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option type ‘bridge’
option ifname ‘eth0.1’
option proto ‘static’
option ipaddr ‘192.168.2.1’
option netmask ‘255.255.255.0’
option nat ‘1’

config interface ‘wan’
option ifname ‘eth0.2’
option _orig_ifname ‘eth0.2’
option _orig_bridge ‘false’
option proto ‘dhcp’

– Simpan kemudian restart

 

Silahkan hubungkan kabel UTP ke port 4/TV dan installasi modul siap dilakukan

 

January 25

Install OpenWrt di Huawei Echolife HG553

dengan diinstall OpenWrt, fungsi router Huawei Echolife HG553 akan lebih banyak, misalkan :

  1. sharing internet dari port LAN yang diubah menjadi WAN
  2. bisa mengenali modem cdma
  3. tethering dari USB Hostless Modem misalnya ZTE MF70
  4. tethering dari HP android
  5. Multi WAN
  6. Samba Server / File Sharing
  7. fungsi lainnya nanti ditambahkan

Ok, lanjut ke langkah instalasi

  1. Pastikan anda sudah beli router Huawei Echolife HG553 ini ya
  2. Download firmware openwrt terbaru disini. saya menggunakan versi barrier breaker
  3. Siapkan kabel LAN untuk koneksi ke Router
  4. Setting IP ethernet komputer secara manual di 192.168.1.2, subnet mask 255.255.255.0 dan gateway 192.168.1.1
Category: Tutorial | Comments Off on Install OpenWrt di Huawei Echolife HG553